DHL Benelux status updates are delayed
Incident Report for Sendcloud
Resolved
This incident has been resolved.
Posted Jan 11, 2017 - 14:00 CET
Investigating
We have some issues with getting the status updates from DHL. We are investigating the issue and we hope to restore the status updates as soon as possible.
Posted Jan 11, 2017 - 11:17 CET