DHL Austria and Germany in degraded performance
Incident Report for SendCloud
Resolved
This incident has been resolved.
Posted about 1 month ago. Dec 11, 2017 - 10:45 CET
Monitoring
We identified an issue with DHL Austria and Germany services and are currently monitoring the situation. Announcements and status updates are currently in degraded performance.
Posted about 2 months ago. Dec 08, 2017 - 12:40 CET