Failing announcements Mondial Relay
Incident Report for Sendcloud
Resolved
This incident has been resolved.
Posted Jul 18, 2019 - 13:11 CEST
Monitoring
Parcels are announced successfully again. We will keep monitoring this.
Posted Jul 18, 2019 - 10:31 CEST
Investigating
We are currently investigating this issue.
Posted Jul 18, 2019 - 10:08 CEST
This incident affected: Carriers (Mondial Relay).