PostNL international shipments failing
Incident Report for Sendcloud
Resolved
This incident has been resolved.
Posted Jul 18, 2019 - 14:01 CEST
Investigating
We are in contact with PostNL to solve the problem for shipments on SendCloud's account. Direct contract are not affected.
Posted Jul 16, 2019 - 18:45 CEST
This incident affected: Carriers (PostNL).