DPD label announcement issue
Incident Report for Sendcloud
Resolved
This incident has been resolved.
Posted May 11, 2020 - 10:51 CEST
Monitoring
DPD implemented a fix which resolved the issues with label announcement. We will monitor the status of DPD.
Posted May 07, 2020 - 15:36 CEST
Investigating
DPD is experiencing issues with label announcements, we are in contact with DPD to get this resolved.
Posted May 07, 2020 - 10:21 CEST
This incident affected: Carriers (DPD).