Issue displaying incoming orders
Incident Report for Sendcloud
Resolved
This incident has been resolved.
Posted Feb 11, 2020 - 13:24 CET
Monitoring
We have implemented a fix and will continue the monitor.
Posted Feb 11, 2020 - 11:04 CET
Identified
We are currently experiencing an issue with displaying the incoming orders. We have identified the issue and are currently working on a fix.
Posted Feb 11, 2020 - 10:17 CET
This incident affected: Sendcloud (Sendcloud Panel).