DHL label announcement issues
Incident Report for Sendcloud
Resolved
This incident has been resolved
Posted Aug 11, 2020 - 11:43 CEST
Update
We are continuing to investigate this issue.
Posted Aug 11, 2020 - 11:34 CEST
Investigating
We are currently investigating the issue
Posted Aug 11, 2020 - 11:33 CEST
This incident affected: Carriers (DHL).