Slow response platform
Incident Report for Sendcloud
Resolved
This incident has been resolved.
Posted Apr 21, 2020 - 13:25 CEST
Identified
We identified an issue with the performance of our platform and are working on a fix.
Posted Apr 21, 2020 - 13:12 CEST
This incident affected: Sendcloud (Sendcloud Panel).