DHL DE label announcement issues
Incident Report for Sendcloud
Resolved
This incident has been resolved.
Posted Apr 09, 2020 - 14:15 CEST
Identified
Due to much activity at DHL DE, label announcements may fail or take longer than expected
Posted Apr 08, 2020 - 13:57 CEST
This incident affected: Carriers (DHL (Germany)).