DPD label failed announcement
Incident Report for Sendcloud
Resolved
This incident has been resolved.
Posted Apr 01, 2020 - 15:26 CEST
Monitoring
Due to much activity at DPD, label announcements may fail or take longer than expected.
Posted Apr 01, 2020 - 11:47 CEST
This incident affected: Carriers (DPD).