Correos tracking status discrepancies
Incident Report for Sendcloud
Resolved
This incident has been resolved.
Posted Jul 30, 2020 - 09:29 CEST
Identified
Correos is experiencing issues with the status of shipments. This may result in tracking statuses not being updated. Also tracking dates and times might be incorrect.
We are in close contact with Correos and they are working on a fix.
Posted Jul 03, 2020 - 09:07 CEST
This incident affected: Carriers (Correos).