Frontend failing to load
Incident Report for Sendcloud
Resolved
This incident is resolved, please reload the platform if you still experience issues.
Posted May 05, 2020 - 10:58 CEST
Identified
The issue has been identified and a fix is being implemented. We are seeing occasional failures in loading the frontend. Please reload the platform if you are experiencing this issue.
Posted May 05, 2020 - 10:06 CEST
This incident affected: Sendcloud (Sendcloud Panel).