DPD DE label announcement issues
Incident Report for Sendcloud
Resolved
This incident has been resolved.
Posted Oct 09, 2020 - 11:36 CEST
Investigating
Untersuchen - Wir untersuchen derzeit diese Situation. / We are currently investigating this issue.
Posted Oct 09, 2020 - 10:54 CEST
This incident affected: Carriers (DPD).