DPD to Pickup Point label announcement issues
Incident Report for Sendcloud
Resolved
This issue has been resolved
Posted Jul 07, 2020 - 13:06 CEST
Identified
We identified the issue, we are collaborating with DPD to fix the issue.
Posted Jun 19, 2020 - 09:33 CEST
Investigating
We are currently investigating this issue
Posted Jun 18, 2020 - 15:18 CEST
This incident affected: Carriers (DPD).