Correos Express label failed announcement
Incident Report for Sendcloud
Resolved
This incident has been resolved.
Posted Apr 08, 2020 - 16:30 CEST
Identified
Correos Express is having issues with label announcements, this results in label announcement being unsuccessful.
Posted Apr 06, 2020 - 15:00 CEST
This incident affected: Carriers (Correos Express).