Colissimo label announcement
Incident Report for Sendcloud
Resolved
This incident has been resolved.
Posted Apr 27, 2020 - 15:08 CEST
Update
We are continuing to investigate this issue.
Posted Apr 27, 2020 - 10:07 CEST
Investigating
Colissimo is experiencing issues. This can result in labels not being announced.
Posted Apr 24, 2020 - 12:38 CEST
This incident affected: Carriers (Colissimo).