DHL DE label announcement issues & contract activation/validation issues
Incident Report for Sendcloud
Resolved
This incident has been resolved.
Posted Aug 10, 2020 - 12:58 CEST
Investigating
DHL DE has currently partial outage for label announcement.
Posted Aug 10, 2020 - 09:02 CEST
This incident affected: Carriers (DHL DE).