Correos Express label failed announcement
Incident Report for Sendcloud
Resolved
This incident has been resolved.
Posted Apr 01, 2020 - 16:36 CEST
Identified
Correos Express is having issues with label announcements, this results in label announcement being unsuccessful.
Posted Apr 01, 2020 - 10:33 CEST
This incident affected: Carriers (Correos Express).