DPD label announcement issues
Incident Report for Sendcloud
Resolved
Due to much activity at DPD, label announcements may take longer than expected
Posted Apr 01, 2020 - 11:12 CEST
Investigating
DPD is having issues with label announcements, this results in label announcement being unsuccessful.
Posted Apr 01, 2020 - 10:29 CEST
This incident affected: Carriers (DPD).