DPD parcel announcements for Germany failing
Incident Report for Sendcloud
Resolved
This incident has been resolved.
Posted Aug 11, 2017 - 15:15 CEST
Monitoring
German users might experience problems announcing parcels, the incident has been reported to DPD and it is monitored.
Posted Aug 11, 2017 - 13:47 CEST