Availability of tracking page is limited
Incident Report for Sendcloud
Resolved
This incident has been resolved.
Posted Jan 14, 2021 - 16:15 CET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 14, 2021 - 13:40 CET
Identified
We are experiencing problems with the tracking page availability. We are working on a fix before that will be deployed before 15:00.
Posted Jan 14, 2021 - 12:50 CET
This incident affected: Sendcloud (Tracking page).