Correos Express label announcement issue
Incident Report for Sendcloud
Resolved
This incident has been resolved.
Posted May 11, 2020 - 11:46 CEST
Update
We are continuing to work on a fix for this issue.
Posted May 06, 2020 - 16:40 CEST
Identified
Label announcement issues at Correos Express, we are in contact
Posted May 05, 2020 - 14:09 CEST
This incident affected: Carriers (Correos Express).