DPD label announcement issues
Incident Report for Sendcloud
Resolved
This incident has been resolved.
Posted May 11, 2020 - 10:52 CEST
Update
We are continuing to monitor for any further issues.
Posted Apr 15, 2020 - 12:36 CEST
Monitoring
We're are monitoring the announcements. They might take longer.
Posted Apr 15, 2020 - 12:36 CEST
Investigating
We are currently investigating the issue. Labels take longer to announce or fail.
Posted Apr 15, 2020 - 09:30 CEST
This incident affected: Carriers (DPD).